PHP

From Limbas Wiki

Jump to: navigation, search
This page contains changes which are not marked for translation.

Limbas benötigt PHP Version ab 5.5 oder höher.
Die zu installierenden Module sind der Anleitung der jeweiligen Distribution zu entnehmen.

PHP Konfiguration

Die PHP-Konfiguration muss in der folgenden Datei angepasst werden:

CentOS Ubuntu OpenSUSE FreeBSD
/etc/php.ini /etc/php5/apache2/php.ini /etc/php5/apache2/php.ini /usr/local/etc/php.ini

Zuerst, sollten die folgenden allgemeinen Einstellungen gesetzt werden:

  • short_open_tag = On
  • register_globals = Off
  • error_reporting = E_COMPILE_ERROR|E_ERROR|E_CORE_ERROR


Desweiteren sollten folgende Einstellungen hinzugefügt werden Sicherheit:

  • magic_quotes_gpc = off
  • file_uploads = On
  • upload_max_filesize = 10M
  • post_max_size = 16M
  • memory_limit = 128M
  • max_input_vars = 10000

Falls nicht PHP 5.4 oder höher vorhanden ist, sollte folgender Eintrag statt magic_quotes_gpc verwendet werden:

  • magic_quotes = Off